Engine Oil Level - I-drive

Roly
BMW Enthusiast
Posts: 10
Joined: 21 Jun 2015, 13:50
Car model: BMW X6 35d

Engine Oil Level - I-drive

Post by Roly » 30 May 2016, 20:30

Hi,
Changed from a 6 series to an X6.... I think it was a good move, however 2 weeks ago I checked the I-drive to see what the oil level was sitting at and it said OMG you have too much oil in here.. the car was serviced a month ago and level was checked on the i-drive and was ok.

Changed the oil level sensor, BMW £137 to look at the car and over £300 for the sensor, local garage bought the part from BMW and the total supply and fit was just over £206, but no change to oil level on I-drive still too high, has anyone got any idea what it could be before I go cap in hand to BMW and have to sell one of my wife's body parts to pay the bill.

User avatar
M60NJP
Site Owner
Posts: 23069
Joined: 12 Oct 2011, 13:22
Car model: 135i M Sport
Isetta 300
Location: Bucks
Location: Buckinghamshire
Contact:

Re: Engine Oil Level - I-drive

Post by M60NJP » 30 May 2016, 21:52

Plan A is surely to dump the oil and replace with the correct amount? Or find a garage with an oil removal suction thing and get them to remove a couple of litres? In either case it'll show on the gauge (downwards) or not (if the sender is duff or there's a wiring fault)......

Can you load an image of what you're seeing?

Maxwell
BMW Enthusiast
Posts: 1387
Joined: 24 Aug 2014, 19:07
Car model: F13 M6
E53 3.0d
E64 650i
E85 Z4
E46 318i
E39 525i
Location: Swindon

Re: Engine Oil Level - I-drive

Post by Maxwell » 31 May 2016, 05:45

Have you checked for diesel in the sump ?

Roly
BMW Enthusiast
Posts: 10
Joined: 21 Jun 2015, 13:50
Car model: BMW X6 35d

Re: Engine Oil Level - I-drive

Post by Roly » 04 Jun 2016, 15:42

Hi and thanks for the replies, I have had a new sensor fitted and the right amount of oil put in (no diesel found), still showing over full even with new sensor fitted. on the i-drive on the level display instead of showing a green bar it shows orange bar to the top and a message for being over filled... I know it's not.

theguvnor
BMW Enthusiast
Posts: 1886
Joined: 01 Feb 2013, 19:32
Car model: E46 M3 Vert
F10 520d M Sport
E34 520i SE Touring

Engine Oil Level - I-drive

Post by theguvnor » 04 Jun 2016, 22:17

Bring back the dip stick! Can't stand sitting there for what feels like an eternity for the car to make up its mind as to how much oil it has when I could've done it in a quarter of the time! And they've take away the only thing I can do under the bonnet . Gits

Roly
BMW Enthusiast
Posts: 10
Joined: 21 Jun 2015, 13:50
Car model: BMW X6 35d

Re: Engine Oil Level - I-drive

Post by Roly » 05 Jun 2016, 14:36

Nice one ..... I agree, it only leaves the washer bottle for me to fill

Roly
BMW Enthusiast
Posts: 10
Joined: 21 Jun 2015, 13:50
Car model: BMW X6 35d

Re: Engine Oil Level - I-drive

Post by Roly » 13 Jul 2016, 18:52

Still in BMW - looks like new software... tried everything else so far...... luckily no charge so far

User avatar
M60NJP
Site Owner
Posts: 23069
Joined: 12 Oct 2011, 13:22
Car model: 135i M Sport
Isetta 300
Location: Bucks
Location: Buckinghamshire
Contact:

Re: Engine Oil Level - I-drive

Post by M60NJP » 13 Jul 2016, 21:25

Frustrating!

You'd think they'd underfill and run it briefly to see if it's a calibration or signalling issue?

Maxwell
BMW Enthusiast
Posts: 1387
Joined: 24 Aug 2014, 19:07
Car model: F13 M6
E53 3.0d
E64 650i
E85 Z4
E46 318i
E39 525i
Location: Swindon

Re: Engine Oil Level - I-drive

Post by Maxwell » 13 Jul 2016, 21:41

If it was me and not a 'MasterTech :)) ' I would have updated the software first after a new sensor was fitted and then calibrated it under the Service plan in the ISTA/D dealer diagnostic software.

But its not me its a 'proper' BMW Tech working along the lines of lets just replace everything and hope the problem goes away :(( 8-|

Roly
BMW Enthusiast
Posts: 10
Joined: 21 Jun 2015, 13:50
Car model: BMW X6 35d

Re: Engine Oil Level - I-drive

Post by Roly » 16 Jul 2016, 18:00

Well.... here is the latest..... the software is ok, wiring ok, sensor ok...... it could be fuel/diesel getting in to the engine some how, it was explained to me but I don't speak bull...so didn't remember any of it... got to run it for 200 miles and see if the level rises.

still no charge and get a free clean when ever it's in BMW. Car is still under warranty so fingers crossed

Post Reply

Return to “Engine & Transmission”