Windscreen washers .

Windscreen washers .

Postby Crimsonrocketship31 » 13 Nov 2017, 13:45

Hi all ,stupid problem just occured,my windscreen washers are just drbbling out fluid hardly reaching the screen,tank is full and motor is working ,I can hear it.Tried unblocking the small holes but that made no difference,so what else could :-! :-! it be.It seems taking it all apart to find out what is wrong is a bit drastic.Anyone got any ideas that I could try.
Crimsonrocketship31
BMW Enthusiast
 
Posts: 27
Joined: 10 Sep 2017, 13:38
Location: Essex
Has thanked: 3 times
Been thanked: 14 times
Car model: Z E89 2009
Location: Essex

Re: Windscreen washers .

Postby FAB_BMW » 13 Nov 2017, 13:58

Maybe pull the pipe off the washer nozzles and see what kind of pressure is reaching them. Have you let them run low of fluid recently as the pumps can get blocked up with the crud in the bottom of the washer tank.
User avatar
FAB_BMW
BMW Enthusiast
 
Posts: 2361
Joined: 13 Mar 2013, 12:46
Location: Warlingham, Surrey
Has thanked: 825 times
Been thanked: 1257 times
Car model: 2003 E46 330d Sport Touring

Re: Windscreen washers .

Postby M60NJP » 13 Nov 2017, 14:47

As above - cheap/crap/old fluid does tend to sludge.

I'm assuming they're not frozen??!!
User avatar
M60NJP
Site Owner
 
Posts: 22879
Joined: 12 Oct 2011, 12:22
Location: Buckinghamshire
Has thanked: 5793 times
Been thanked: 5671 times
Car model: 135i M Sport
Isetta 300
Location: Bucks

Re: Windscreen washers .

Postby Crimsonrocketship31 » 14 Nov 2017, 12:20

Hi all thanks for replies,had a mate round this morning and we took the washer tank out ,cleaned it thoroughly and cleaned the 2 filters which were completely blocked with slime and my washers are now working as they should.
Crimsonrocketship31
BMW Enthusiast
 
Posts: 27
Joined: 10 Sep 2017, 13:38
Location: Essex
Has thanked: 3 times
Been thanked: 14 times
Car model: Z E89 2009
Location: Essex

Re: Windscreen washers .

Postby Crimsonrocketship31 » 14 Nov 2017, 12:25

Possibly 9 years of slime in the filters. Must admit that I never thought about this being the problem until going into the BMW forums where it seems it is a common problem but not any more.
Crimsonrocketship31
BMW Enthusiast
 
Posts: 27
Joined: 10 Sep 2017, 13:38
Location: Essex
Has thanked: 3 times
Been thanked: 14 times
Car model: Z E89 2009
Location: Essex


Return to General

Who is online

Users browsing this forum: No registered users and 3 guests

cron